Symptom
When attempting to book a meeting through the Public Calendar URL (read more on the public calendar here), the prospect is seeing an error at the top of the page after clicking the Book Meeting button. This error prevents any meeting from being booked on the user's calendar using that link.
Applies To
- All users and prospects
-
Public Calendar URL
- Meetings
Resolution
To resolve, we first want to establish what default meeting type the user is using in their calendar settings. To find this, navigate to the user's profile and click the Calendar tab. You will then locate the section labeled "Default meeting type" and note the selection. For the below, the default meeting type is "Qualification".
Next, navigate to the main Meetings section on the left-hand side, click the Meeting Types tab, and click on the correct meeting type. In this case, we can see from the below screenshot that the company variable, which should be {{company}} is incorrectly entered as {{company}. You will look for any variables that are incorrect, edit the meeting type, and click Save.
Note: If you are unable to edit the meeting type, you will need to loop in your org's admin and they can make the adjustment for you.
Please also ensure that an owner is assigned to the user's selected meeting type. Since the owner field is required, if there is no assigned owner, prospects will receive an error when booking meetings.
Cause
The cause is an incorrectly formatted variable on the default meeting type being used by the user. You can read more about profile meeting types here and more about creating and editing org meeting types here.