Symptom
When attempting to sync records from Salesforce to Outreach, the below error pops up.
Applies To
-
Admins
- Salesforce Plugin Sync
Resolution
To resolve the issue, you will need to map the user and attempt to pull again. You will need to do this for every user assigned to records in Salesforce that exist in Outreach but are not mapped. To do this, navigate to the User <> User plugin settings in Outreach, select the Record mappings tab, and add the mapping.
Cause
The record you are attempting to sync is owned by a user that is not currently mapped in the Salesforce plugin settings. Because of this, Outreach will try to create a new user based on the user object sync settings. In this case, we're unable to do so because the email address already exists on a user in Outreach.