Symptom
Error 'Failed to override step templates' occurs when trying to add a prospect to a sequence.
Applies To
Outreach sequence
Variables
Sequence edit permissions
Resolution
Check the variables used in the template and whether the prospects in question have the values entered in the fields to which those variables refer.
If not, the user needs to enter values in those fields of the profiles of the prospects he wants to sequence. Or, he needs to remove those variables from the email template.
Or, if an admin can add the same prospects to the same sequence, that would indicate the issue is related to sequence edit permissions. In that case, check those permissions, and if the affected user does not have the permission to edit the sequence in question, that would be the cause of the issue.
Cause
Value to which a variable refers to not being present in the profile of the prospect the user tried to add to the sequence.
If an admin can add the same prospects to the same sequence, that would indicate the issue is related to sequence edit permissions. In that case, check those permissions, and if the affected user does not have the permission to edit the sequence in question, that would be the cause of the issue.