Symptom
Activity being completed on a prospect (e.g. calls, emails, meetings) sync to Salesforce but do not appear as related activity under the Salesforce opportunity.
Applies To
- Outreach admin
- Opportunities
- Prospects
Resolution
The first step in resolving this issue, assuming that the Opportunity object is already synced properly, is making sure that you have your Opportunity Contact Role object synced up to Outreach. To do this:
1. Navigate to your CRM settings and click on the Opportunity Contact Role object.
2. Clicking into the Opportunity Contact Role option, Inbound Create and Update should be enabled if you want any new contact roles from Salesforce to pull into Outreach, or any updates to reflect in Outreach, as well.
The standard field mappings are shown below.
3. You will likely want to make sure you can easily bring them into Outreach but you may not want it to be automatic. In that case, select the Polling frequency of "Only when synced manually".
4. Next, click on Validations on the left-side navigation Administration Menu under Records and click the Add validation rule button at the top right.
5. You'll want to make sure the Type is Prospect role and the Field is Role. After clicking Next, you can either manually add each Opportunity Contact Role, or click the Poll button to bring them in from Salesforce. Remember that each role needs to match exactly to the one in Salesforce.
6. Click Save and you're done! Any new activity completed in Outreach will sync to Salesforce, as normal, but it will also be added as related activity under the opportunity.
Cause
The primary cause is that the opportunity contact role is not mapped to the Prospect role validation in Outreach. If the contact roles are mapped and activity is not syncing, you'll want to troubleshoot the CRM plugin and activity not syncing entirely: