Symptom
You are viewing an actual record in SFDC, but the Outreach Everywhere extension is showing the New Prospect page instead of the associated Outreach record. Even when you try to go and view a different record, it doesn't update and keeps displaying the New Prospect page, as if you were creating a brand-new record in Outreach.
Applies To
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Outreach Everywhere Chrome extension
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Salesforce
Resolution
Close the OE extension. Instead of opening the OE extension by clicking on the icon in the top right of the Chrome browser in the extension bar, or opening the slide-out, click on the Outreach decorations/icons next to the SFDC record you want to view. After the OE extension opens up, any new record you view will automatically show in the extension.
TIP: You can also click on the Outreach decorations/icons next to the email and phone numbers in SFDC to action that in the OE extension.
Cause
If you open the OE extension from a list view, or page that isn't looking at a specific record, it will show the New Prospect page. The system thinks you want to create a new prospect so you're now in that workflow. If you don't want to do that, you can click the back button in the extension, close the extension, and/or click the Outreach decorations/icons next to the name of the record you're viewing in Salesforce. As long as you're viewing an actual record, it should display that in the extension.