Symptom
The prospect import fails with the error message, "Record not found", as shown below.
Applies To
-
Importing Prospects
-
All users
Resolution
If the ID on the CSV is a Salesforce ID or Dynamics ID, map the field to External ID. Otherwise, map to a custom field or the Not mapped option.
Cause
Prospects being imported are new to Outreach but an ID on the CSV is being mapped to the ID (Outreach Internal) field on step 2 of the import process. The ID (Outreach Internal) field can only be mapped when the ID provided on the CSV matches the ID of a prospect already in Outreach.