Symptom
Locked or deactivated users are unexpectedly appearing in Outreach Reports when filtering for Teams, such as the Daily Activity report, the Team Calls report, etc.
Applies To
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Managers
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Outreach Admins
Cause
When aggregating data for reports and filtering by teams, any activity that took place within the filtered dates while the user was assigned to the team will show up in the related reports, even if the user is deactivated later. This is done to prevent retroactive reports from being skewed or missing data when a team member leaves, but you may see locked users appearing in these reports for longer than expected if they still have outstanding tasks.
Resolution
When viewing team reports in Outreach, you may see deactivated or locked users appear in your activity reports for certain dates. These users will be indicated with a small padlock icon next to their name in the report table, or when searching for users in the report filter list. There are a few solutions we recommend to remove locked users from your team reports:
- Ensure all overdue tasks for the locked user have been re-assigned to active users. If a locked user is still set as the owner on tasks in Outreach, they will appear in the Daily Activity report, even if they don't have any other matching activities.
- If you are unable to remove the user's overdue tasks, you can instead remove them from the team going forward to prevent them from appearing in future reports (even if they have matching actions). To do this, you'll need to unlock the user, remove them from the team, and re-lock them. This will prevent their user profile from appearing in team reports going forward, since they will no longer be on the team. Historical data for actions they performed in Outreach when they were assigned to the team will be retained, and they'll still appear in past team report data for those dates.
Note: You will need Admin-level access to lock and unlock users. Please see our guide on Outreach Seat Management for further instructions on locking user seats.
If a user was not a member of the team in a given time frame or if the user did not have matching activity given selected filters, they will not show in the report. So, locked users should filter out of your reports over time as long as their open tasks have been cleared.