Symptom
When an Outreach admin is trying to delete a profile, they are experiencing the following error: "cannot destroy profile while users are assigned to it."
This usually happens when there are locked users associated with the profile and they are not visible as shown on the screenshot below.
Applies To
-
Admins
- Governance
Resolution
- Log in to Outreach.
- Navigate to the Users page.
- Remove all filters.
- Filter by the profile that needs to be deleted.
- Edit the users and remove the profile.
- Navigate to the governance profile page and delete the profile.
Cause
The locked users are not visible from the profile.