Symptom
Email sent to multiple prospects in the 'To' field doesn't appear on all prospect records emails tab or activity tab and doesn't sync to CRM for all the prospects.
Applies To
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CRM
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Activity sync
Resolution
Check the activity / emails tab and corresponding record in Salesforce for the first prospect in the 'To' field, and email activity should be present.
Cause
This is because we sync emails only to the first prospect in the 'To' field and not to all prospects that email was sent to. The first prospect recipient in the email is considered the Primary prospect for that activity, and we only sync that activity to the Primary prospect only. Email should appear in 'Emails' tab for all the prospects, however in will appear in the activity tab for the first prospect only. Also, email will sync to the first prospect corresponding record in SFDC only.