Symptom
User is calling into Thailand using a TH number, but it's not connecting and failing the call.
Applies To
-
Imported personal TH phone numbers
-
Outbound calls into Thailand
Resolution
You must purchase and use an approved Twilio TH phone number.
Note - you will need to submit a TH regulatory bundle submission to be able to purchase TH numbers. Please see Twilio's requirements here.
Cause
Thailand has imposed strict control on VOIP calls. Only one number provider can successfully terminate the call with their CLI. If you need to terminate a call in Thailand with a CallerID from Thailand, it must be a Twilio Thailand Number provided by said provider, as a pass-through of the local CallerID will not work. Only Twilio numbers will work, or the call will fail.
Please see Twilio's guidelines for calling into Thailand - https://www.twilio.com/en-us/guidelines/th/voice