Symptom
A Dependency Sync Failure error appears when a CRM user is attempting to sync.
Applies To
- Outreach Admins
Resolution
Outbound Sync
For objects that can be outbound created, enable the outbound create toggle. If any conditions are preventing the dependent record to be outbound created, update it such that it becomes syncable.
If the object cannot be outbound created, set up inbound sync for that object, and inbound sync the unresolved records. Alternatively, if the number of unresolved records is small, you can also manually map the Outreach and CRM records in the Record Mappings tab.
Inbound sync
Do the reverse of outbound sync above.
Cause
Dependency sync failure errors occur when we fail to sync a record because we are unable to create one of the dependencies. For example, creating an OpportunityContactRole record in Salesforce requires that we are able to create the Contact if it does not already exist in the CRM. If we are unable to create the Contact (due to permissions; sync configuration), you will encounter dependency sync failure.
Here’s some of the examples of the errors you will encounter
- dependency skipped: User: Outbound User creation is disabled
- dependency skipped: Lead: Outbound Lead creation is disabled, Contact: Outbound Contact creation is disabled
- dependency skipped: Lead: Outbound Lead creation is disabled, Contact: Condition not satisfied because namedAccount is false
- dependency skipped: Lead: Condition not satisfied because custom1 is empty, Contact: Outbound Contact creation is disabled
- dependency skipped: Lead: Condition not satisfied because eventName is empty,stage is 2,stageName is Actively Working, Contact: Condition not satisfied because accountName is empty
- Inbound OpportunityStage creation is disabled