Symptom
Invalid Picklist Value error in CRM Sync.
Applies To
- Outreach Admins
Resolution
Review field validation rules for the Outreach field that is failing to sync with the CRM and make sure the validation rules match what you have in your CRM.
Cause
Invalid picklist value errors occur when the field value(s) on a record do not meet picklist validation rules in the destination system and we are not able to sync the record. Here’s some of the reasons field validation could fail:
- Field value is empty/null and the destination is a picklist field which requires a value to be selected.
- Field value in the source system is not in the list of picklist values in the destination system.
- API name of the picklist value in Salesforce does not match the field value in Outreach.
- Option set value for the field in Microsoft Dynamics does not match the field value in Outreach.
Additional Information
How to create/delete a picklist validation?
How to update prospects and accounts to match validation rules?