Symptom
The purpose of this article is to provide direction to Outreach Admins on addressing Invalid Data Type errors in CRM sync.
Applies To
- Outreach Admins
Resolution
- Make sure that the field mapping is correct. If possible, delete and create the field mapping.
- Make sure that the data type of the fields in Outreach and the CRM are similar.
- If a field is a lookup field in Outreach or the CRM, ensure that the corresponding foreign key is synced to the appropriate system. Enable the “mapped” toggle in Advanced Settings, and select an appropriate “external mapped type” to sync the dependent record, and resolve the correct ID.
- Remove the data in Outreach or the CRM. You can use wildcard searches in Outreach to identify the records impacted and then bulk edit the fields to remove the data if the cleanup is on the Outreach side.
- How to do wildcard search in Outreach.
- For Microsoft Dynamics errors refer to this guide.
Cause
Invalid data type errors occur when the actual value of data in a field does not match the data type for that field.
Here’s some of the reasons you will see this error
- An ID field containing a different type of data such as a name, or a date.
- The ID value in the field does not match the external mapped type in advanced settings.
Additional Information
How to map meeting type field to CRM
How to delete a field mapping in Outreach
How to map opt-out fields in Microsoft Dynamics
How to setup advanced field mappings in Outreach