Symptom
User is experiencing an error when trying to send an email in Outlook with the Outlook Add-in.
Applies To
-
Outlook Client and Web version
- Outreach Users
Resolution
If this error occurs when you try to send an e-mail in Outlook, please follow the steps below:
- Make sure network connection is stable
- Restart the Outlook client
- Refresh the tab on the Web version
- Restart client on Mac / Windows
Cause
Normally, when everything works as expected, users don’t see any "Add-in X is processing message" popups when sending emails.
In some cases, when users hit "Send" button in Outlook to send an email, they see the following popup: "Outreach is taking longer than expected".
The popup appears 5 seconds after the "Send" button is clicked, and eventually changes to one of two states: "Timed out" after 5 minutes or "Processed" between 5 seconds and 5 minutes.
The "Timed out" state is not expected, and in most cases it's related to internal Outlook issues and Outlook's inability to properly invoke the Outreach add-in.
The "Processed" state is expected behaviour and is related to the slowness of Outreach or the Microsoft APIs, which can happen at busy times such as Monday mornings.
In any case, the problem should be reported to our support team for further investigation if it persists.
Additional Information
Outreach Sales Engagement Outlook Add-In 3.0 Overview