Symptom
When trying to manually sync a record, an error pops up indicating that the 'Condition not satisfied because id is xxx':
Note that each record in Outreach is automatically associated to a unique ID which can be found in a record export from the system or by the ID number in the URL when viewing that record.
Applies To
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Outreach Users
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Outreach Admins
Resolution
To resolve this issue, your Outreach Admin need to review and remove the current condition to allow the sync to happen:
Note that it may need to be updated for each objects if applicable (Contacts, Leads, etc).
Cause
This is happening due to the sync conditions where the Record ID is set to sync 'If ID (Outreach internal) is empty' and since Outreach records are automatically associated to a record ID, this condition will prevent the sync as expected.
Additional Information
How does Outreach dedupe records?
Determine an ID of an Outreach Asset
CRM Set Syncing Conditions Overview (set conditions to sync only specific records)