Symptom
When attempting to sync records between Outreach and Microsoft Dynamics users can encounter an error "Principal User is missing 'prvReadEntity' privilege for entity 'entity' for example:
Applies To
- Microsoft Dynamics
- CRM integration
Resolution
To resolve this issue ensure the CRM integration authorization user has Read/Write privileges on the relevant entity and prvRead fields in Microsoft Dynamics.
Cause
This issue occurs when the integration user does not have read/write privileges. Often this is due to the Power Platform user lacking a license. See additional information below for the relevant Microsoft Documentation.