Manually syncing records using the "find corresponding object" option results in error

Created by Shawn Stensberg, Modified on Mon, 9 Feb at 11:01 PM by Alsabana Sahubarali

Symptom

Attempting to find a corresponding object in Salesforce for a record in Outreach, one of the following errors may occur:

  • "No equivalent Lead found, Object is already mapped to Prospect<#>"
  • "No equivalent Contact found, Object is already mapped to Prospect<#>"
  • "No equivalent Account found, Object is already mapped to Account<#>"

Prospects_-_Outreach_2023-02-07_at_7.24.38_AM.jpgerror.jpg

Applies To

  • Outreach Admins
  • CRM Syncing

Resolution

  1. Navigate to the CRM Advanced plugin settings in Outreach.
  2. Verify the merge and delete function (described here) is enabled.
  3. Verify inbound update is enabled for leads, contacts, or accounts, depending on the error you're seeing.
  4. Create a new record in Salesforce that will be used to merge the duplicate records in Outreach.
  5. Manually map the duplicate record in Outreach to the newly created record in Salesforce.
  6. Merge the two Salesforce records, which will merge the records in Outreach.

Cause

This issue occurs because there are duplicate records in Outreach and only one record in Salesforce. The duplicate cannot be mapped because the record in Salesforce is already mapped to a second record in Outreach.

 


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