Outreach Activity in CRM Attributed to Wrong User

Created by Aye Myat, Modified on Mon, 9 Feb at 11:01 PM by Alsabana Sahubarali

Symptom

Activity synced into your CRM is being shown as "Created By" as specific employee, rather than a dedicated Integration User

Applies To

  • Outreach Admins

  • Salesforce / Microsoft Dynamics Admins

Resolution

The Outreach<->CRM plugin should be connected using the Salesforce/Dynamics credentials of a dedicated Plugin Authorization User. This user should be given full SysAdmin rights within the CRM, and this user seat should never be used by an actual employee. Ideally, this user seat should not be used to connect any other integrations to your CRM, as doing so will make actually determining which integration prompted activity very difficult.

We recommend you create a dedicated user within your Salesforce/Dynamics environment with a name like "Outreach Plugin User" and use these credentials to connect the plugin, as discussed here: How To Reconnect and Update User Authorization for CRM Plugins. Any Admin user can reconnect the plugin, they just need to be sure to connect to Salesforce/Dynamics using the credentials of their dedicated integration user

Cause

Activity within your CRM performed by the plugin (including, but not limited to: tasks, activity, field updates, and record creation,) will be associated with the Salesforce/Dynamics user whose credentials were used to connect the Outreach plugin. If an employee uses their own CRM credentials to connect the plugin, all activity will be "Created By" that user, which can impact reporting.


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