Symptom
The trigger is active and does not fire despite all conditions being met.
Applies To
- Outreach Users
- Outreach Admins
Resolution
In some cases, switching the trigger frequency from 'run once per target' to 'indefinitely', then update the target record in Outreach will force the trigger to fire again.
Cause
If the trigger frequency is set to 'run once per target', chances are that it has already tried to fire but failed in the backend and will not fire again, unless you update the frequency to 'indefinitely'.
ie: a prospect's owner mailbox is currently disabled, hence unable to send emails out.
The trigger is set to add your prospect in a sequence, including an email step and all conditions are met for the trigger to fire.
The trigger will still try to fire in the backend but will fail because of the disabled mailbox but will not show in the activities tab in Outreach.
Additional Information
How To Create an Outreach Trigger
Why is my trigger not firing for all prospects on the preview?
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