Symptom
When using the Outreach add-in for Outlook, when you click away from the email window immediately after attempted send, your email is saved to draft instead of sent to the intended recipient(s).
Using the Outlook Native Windows App
When forwarding or replying to a message directly from the Reading Pane, you receive a dialogue warning with the following message: An add-in prevented this message from being sent. It will be saved as a draft. (If you select OK, the message will be saved as a draft.)
Note: This behavior does not occur when you open the message in a separate window and reply or forward it from there, or when composing a new message.
Using Outlook for Web
You do not receive a warning dialogue from Outlook, but the message is saved as a draft silently. This behavior happens for every message, regardless of whether it is sent from the Reading Pane or composed as a new message.
Please Note |
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This experience is currently expected behavior rooted in how Outlook itself is architected to engage its processing of add-in activity. It may take less-than-one to several seconds for the send action to process and complete, during which time, a click somewhere else onscreen will trigger the above. Learn more here. |
Applies To
- Outlook Add-in Users
- Outreach Admins
Resolution
Generally, this experience can be avoided by the user simply pausing any continued activity onscreen until the Outlook add-in has fully completed its processing routine in sending the email.
Additional Workarounds
Out of the Box Workarounds
OPTION 1: Users of the Outlook native Windows app can instead open the message in a new window and reply or forward from there. (Note: This is not possible for Outlook for Web.)
OPTION 2: Users of the NEW Sales Engagement Add-in via the Outlook native Windows app can speed up the email processing by disabling the Outlook add-in when emailing a non-prospect. Caveats:
- Does not apply to the legacy add-in
- Does not apply to Outlook for Web
- Does not fully prevent emails from being saved to draft
Blocking dialogue for New Outlook Add-in [BETA]
Admins who want to prevent users from clicking away (systematically enforcing completion of the Outlook message processing routine) can do so by enabling a pop-up blocking dialogue during processing. This solution is currently in private beta and only available in the new Outlook add-in. If interested in testing it, contact Outreach Technical Support for enablement.
The blocking dialogue prevents users from clicking anywhere else until the message is processed and sent. This dialogue does not speed up or slow down the message processing, and it automatically closes when the message is sent.
Actions offered via dialogue
The dialogue serves as an escape hatch in case sending the message takes longer than expected. Users can close the dialogue and go back to edit the message if needed.
The user also has an option to Send without Outreach. If clicked, the email is immediately sent without Outreach features that require a message to be synced to Outreach, including tracking, sequences, reminders, and more.
When doesn’t the dialogue trigger?
- When you disable the Outlook add-in or sign out of the Outlook add-in, the dialogue is not displayed.
- The message will not display for users with Outlook for Mac.
Dialogue delay
The dialogue triggers 800 milliseconds after clicking Send. (This might take longer when on a slower network).
This delay ensures that the dialogue doesn’t trigger for emails that are processed quickly but trigger fast enough to prevent users from clicking away when the send takes longer. If you are on a slower network, we recommend contacting Outreach Technical Support and requesting the 0s dialogue delay. Further modifications of the dialogue delay are available upon request.
The dialogue displays for all emails, such as prospect, non-prospect, internal emails, forward, reply, new message, and emails sent from the reading pane, and from the new window.
How to enable the dialogue in Private Beta
Contact the Outreach Technical Support team for enablement.
- Confirm if you want to enable this for the whole organization, or only with certain users. We recommend testing with a few users before rolling it out.
- Share your feedback with our support team.
Cause
The core issue sits with Outlook itself and not the add-in. It impacts all add-ins associated with Outlook—not just Outreach's.
This is the sequence of events in the Outlook architecture:
- Outlook, as a native app, initiates a browser engine for the add-in to run. (This applies to any add-in in their ecosystem — not just the Outreach add-in.)
- The Outlook add-in API is loaded.
- The add-in itself is loaded.
- The add-in processes the email.
Across extensive testing, we've found these four steps take about two seconds to complete in full. On a slower network or VPN connection, times have been observed in the four- to five-second range. If a user clicks elsewhere onscreen before this processing has fully completed, it will presume the user is still working on drafting the email and initiate the save-as-draft routine.
Microsoft has acknowledged that Outlook processing takes longer than desired, and their team is actively working on improvements that will result in faster load times for any add-in-processed mailings. While we look forward to that, we do not have full visibility into their roadmap to deliver these improvements.