Symptom
When you try to sync updates from Outreach to Salesforce you see the error "You do not have permission to make changes in Salesforce. Please contact your manager to make these changes on your behalf, or ask your Salesforce admin to adjust your Salesforce permissions" in the Outreach user interface, activity feed or CRM error export.
Applies To
Salesforce
CRM integration
Permissions
Resolution
Here are some elements that you should check in SFDC if you see this error:
- You should ensure the plugin authentication/connecting user has the necessary field level security permissions
- Do you use record types? If so make sure that the the plugin authentication user has access to all required record types.
- Are there any look-up or master detail fields on the object in question? If these types of fields are being updated then make sure that the plugin authorization user has access this object / records.
- Do you use Apex? If so you may have a trigger that fires on the the update of a record, you will need to make sure that the plugin authentication user has profile access to the relevant Apex classes. Alternatively set the trigger to fire with a delay or after the record update has been saved.
- If you have any workflow rules or assignment rules that send an email when the record is saved then you will need to make sure that the plugin authentication user has the send email permission and has access to the email folder that contains the mails that are sent rules are triggered.
- Do you restrict record or field updates to the user who owns the record? If so please allow the plugin authentication/connecting user to make updates to records they do not own or remove the restriction.
Cause
"You do not have permission to make changes in Salesforce. Please contact your manager to make these changes on your behalf, or ask your Salesforce admin to adjust your Salesforce permissions" indicates the user (plugin authentication/connecting user) making the update does not have access to a related element that is required for the record to be updated and saved in Salesforce.
There are a number of specific examples of what might be the cause but these will vary from organization to organization depending on the configuration of your Salesforce instance.
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