MSFT Dynamics Principal User is missing prvReadEntity privilege

Created by David Sullivan, Modified on Mon, 9 Feb at 11:01 PM by Alsabana Sahubarali

Symptom

When attempting to sync records between Outreach and Microsoft Dynamics users can encounter an error "Principal User is missing 'prvReadEntity' privilege for entity 'entity' for example:

Applies To

  • Microsoft Dynamics
  • CRM integration

Resolution

To resolve this issue ensure the CRM integration authorization user has Read/Write privileges on the relevant entity and prvRead fields in Microsoft Dynamics.

Cause

This issue occurs when the integration user does not have read/write privileges. Often this is due to the Power Platform user lacking a license. See additional information below for the relevant Microsoft Documentation.

Additional Information

https://learn.microsoft.com/en-us/power-platform/admin/global-service-administrators-can-administer-without-license


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article