Assigned field in Outreach shows old owner and new owner when syncing from Salesforce

Created by Shawn Stensberg, Modified on Mon, 9 Feb at 11:02 PM by Alsabana Sahubarali

Symptom

When pushing ownership changes from Salesforce to Outreach, the Assigned field is showing the previous owner and the new owner. 

Applies To

  • Admins

  • Prospects, Accounts, and Opportunities

Resolution

To resolve, navigate to the Salesforce plugin within Outreach. You will need to open any object that is impacted by this issue, which may include Contact <> Prospect, Lead <> Prospect, Account <> Account, and Opportunity <> Opportunity. On each object, scroll down to the Set field mapping section and make sure the below two mappings are present, Owner ID <> Owner and Owner ID <> Assigned.

 

Outreach_2023-02-17_at_12.52.35_PM.jpg

 

Once the mappings are added, click on the 3 vertical dots next to each and select the Advanced settings option. You will want to map these fields to the User object, as shown below.

 

Outreach_2023-02-17_at_12.51.46_PM.jpg

 

Click done and save. Do this for each object you want to make this change on.

Cause

Multi-User Assignment, or MUA, allows you to assign multiple users to a single record. If you are using the Salesforce plugin to push ownership changes and you do not have both the Owner and Assigned fields mapped in the plugin, you will see the issue of the old and new owners of a record both appearing. under the Assigned field.

Additional Resources

Multi-User Assignment Overview

How to Set Up Multi-User Assignment

Multi-User Assignment Migration Overview

Multi-User Assignment APIs

 

 

 

 

 

 

 


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