"Resource does not exist in the external system" error when syncing leads from Salesforce to Outreach

Created by Shawn Stensberg, Modified on Mon, 9 Feb at 11:02 PM by Alsabana Sahubarali

Symptom

When attempting to import or sync a Lead from Salesforce to Outreach, an error like the one below appears, where New_MQL represents one of the Lead Status API Names in your Salesforce environment.

Prospects_-_Outreach_2023-02-16_at_2.28.27_PM.jpg

Applies To

  • Salesforce Admins

  • Outreach Admins

  • Salesforce Plugin

Resolution

To resolve this error, make sure there is a one-to-one exact match between the API Name and Value on your Lead Status list. In this case, the Value should be MQL and the API Name should also be MQL.

Cause

This error is caused by one or more Lead Statuses having an API Name that is different that its corresponding Value. As we can see in the below example, the status MQL has an API Name of New_MQL, which does not match the Value. The plugin relies on both being the same in order to properly function.

Object_Manager_Salesforce_2023-02-16_at_2.32.45_PM.jpg


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