Salesforce Import Error: "A prospect with this email address already exists in Outreach and prospect is in the recycle bin."

Created by Shawn Stensberg, Modified on Mon, 9 Feb at 11:02 PM by Alsabana Sahubarali

Symptom

When attempting to import a prospect from Salesforce using the Outreach Everywhere Chrome extension, an error pops up: "A prospect with this email address already exists in Outreach and prospect is in the recycle bin."

 

Applies To

  • Salesforce import

  • Prospect creation
  • Salesforce sync
  • All users

Resolution

To resolve the issue, navigate to Outreach and then to the main prospects page. From there, filter for Recycled prospects (shown below).

You can then click the horizontal 3 dot menu on the far right on the row of the prospect you want to target. Choose restore if you'd like to keep the record and sync Salesforce to it, or delete it so you can create a new record.

Cause

The cause of this issue is when a prospect you're attempting to create/import from Salesforce already exists in Outreach in the Recycle Bin. The Recycle Bin is a temporary holding place for prospects who have been deleted in Salesforce. If they were tied to an Outreach record, that record would be flagged as deleted and moved to the Recycle Bin.

Additional Resources

How To Retrieve and Restore Prospects From The Recycle Bin

Salesforce Record Merge & Delete FAQs


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